Question about versions and branches

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Question about versions and branches

P.N.

Hello!

I've got rosegarden 4.1.0 on my Gentoo Linux machine (which doesn't any
more exist). Now I want to update my linux, and Gentoo wants to install
rosegarden 1.4.0 (marked as latest stable version). These versions seem
to be taken from 2 different branches, so my question is: Which are the
consequences, if I'm installing version 1.4.0? I.e. what are the
differences in performance and resource requirements?

Kind regards

Peter Nabbefeld


-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
Rosegarden-user mailing list
[hidden email] - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user
Reply | Threaded
Open this post in threaded view
|

Re: Question about versions and branches

D. Michael McIntyre
On Wednesday 25 July 2007, Peter Nabbefeld wrote:

> consequences, if I'm installing version 1.4.0? I.e. what are the
> differences in performance and resource requirements?

It's hard to remember, really.  1.0 (or Rosegarden-4 1.0) is extremely ancient
and obsolete.  Somewhere in there, we decided to dispense with the
confusing -4 (to separate the current line of Rosegarden from the prehistoric  
Rosegarden 2.x) and simply release as Rosegarden again.  That might have been
Rosegarden 1.4.0.

The current version is 1.5.1 I think.  It's hard to quantify how it differs
from 1.0, because we've done so much over such a long period of time.  It
uses a different build system, it includes many new features, and fixes
untold bugs.  I wouldn't really expect the resource usage in of itself to
vary that much among versions, but I'd much rather use the newest one than
1.0 for a variety of reasons.
--
D. Michael McIntyre

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
Rosegarden-user mailing list
[hidden email] - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user
Reply | Threaded
Open this post in threaded view
|

Re: Question about versions and branches

Brendon Oliver-2
In reply to this post by P.N.
On Wednesday 25 July 2007 21:52:32 Peter Nabbefeld wrote:

> I've got rosegarden 4.1.0 on my Gentoo Linux machine (which doesn't any
> more exist). Now I want to update my linux, and Gentoo wants to install
> rosegarden 1.4.0 (marked as latest stable version).

I'd highly recommend you get the pro-audio overlay for your gentoo system (can
be installed through layman - if you don't have that, then emerge layman
first).  

Once installed, that will allow you to emerge the current Rosegarden version
1.5.1 (via pro-audio overlay).  

As the name suggests, pro-audio also has a bunch of other audio & multimedia
related apps that either a) you won't get through the core gentoo ebuilds, or
b) are more up to date than what's in core.  Think of it as kind of like
planet CCRMA for gentoo ;-)


Cheers,

- B.


--
Support your local Search and Rescue unit -- get lost.

 09:51:38 up 22:37,  2 users,  load average: 0.54, 1.16, 0.78


-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
Rosegarden-user mailing list
[hidden email] - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user